
iBoutique.MALL Back Office Overview  

Home -> Welcome 

 

Home  page  of  the  back  office.  On  this
page, the administrator could find links to
the  internal  pages  of  the  back  office
application  allowing  him  to  handle  the
website. 

The functionalities in the back office are divided in categories. The members of the Administrators group have access to all
the categories and pages in them. The main administrator can create different back office groups with different permission
sets associated with them and assign them to the different user stores packages. In such way, when a store administrator
logins to the back office, he will see the appropriate menus leading to the pages he is allowed to access. 
By default  iBoutique.MALL comes with one back office group created  by default  "Basic"  with permissions  to access  the
important pages to administrate an user store. The administrator can alter the permissions for this groups as well as create
other groups with different permissions and use them after that when he creates the store packages. 

Iboutique.MALL, a product of NetArt Media www.netartmedia.net



Home -> Profile 

 

This  page  could  be  used  by  the  store
administrators  to  modify  their  personal
information. The initial user information is
recorded  when  the  user  signs  up  and
creates his store from the Signup page on
the front site. 

Home -> Package 

 

On this  page  the  store  administrator  can
see information for his current package and
switch to another package if he wishes. A
detailed  overview  of  the  store  packages
and how they could be used in practice can
be found in the "Packages" doc file. 
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Home -> Connections 

 

The administrator could see on this page a
report about the connections to the back
office application. The unsuccessful logins
are displayed in a separate table, for each
record  the  administrator  can  see  the  IP
address and the date and time of the login
attempt. 

Home -> Change Password 

 

From this page the administrator and the
back office users can change the passwords
they  use  to  access  their  personal
administration space. 
After  the  password  is  modified,  the
administrator will have to login again with
his new username and password. 
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Stores -> Users 

 

The  page  provides  functionality  to  the
main  administrator  to  monitor  the
users/stores and modify the information for
them. 

Stores -> Packages 

 

The store packages provide functionality to
define  different  permission  sets  for  the
back office resources as well as different
number of allowed products that the store
administrator can upload. This page should
be  used  by  the  main  administrator  to
manage  the  available  store  packages.  A
detailed  overview  of  the  store  packages
and how they could be used in practice can
be found in the "Packages" doc file. 
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Stores -> Payments 

 

On  this  page  the  main  administrator  can
monitor  the  payments  done  by  the  store
administrators  for  their  stores  hosting
service.  Please  note  that  the  payments
done by cheques and bank wire should be
manually  validated.  Detailed  information
can be found in the "Packages" doc file. 

Stores -> Advertisements 

 

The  main  administrator  can  put
advertisements  on the  user  stores.  These
advertisements can be displayed in 4 zones
around the user website. On this page the
administrator  can  manage  the
advertisements displayed in these 4 zones.
Please  note  that  there  is  a  separate  doc
file  describing  this  functionality  -
"Advertisements". 
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Products -> Categories 

 

The  page  provides  functionality  for
management  of  the  product  categories.
iBoutique.MALL  supports  multilevel
categories, on this page they are presented
as a tree. Every item in the tree (category)
can be selected with a left mouse click and
then  by  clicking  with  the  right  mouse
button the administrator can see a context
menu with different options. Please look at
the products management manual for more
information  about  handling  the  product
categories. 

Products -> Products 

 

The products page should be used to enter
new  products  as  well  as  to  modify  the
existing  ones.  On  this  page  the
administrator  can  see  the  different
categories  and  products  structured  as  a
tree showing their hierarchy. When clicking
on  a  category  name,one  can  see  the
available products in this category as well
as  add  new  products  to  the  selected
category.  In  order  to  directly  edit  the
information  for  a  selected  product,  the
administrator has to click on his name - a
new  page  having  the  current  product
information  stored  in  editable  fields  will
show  up.  Please  refer  to  the  products
management  manual  for  additional
information. 
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Products -> Settings 

 

Some general  product layout  settings  can
be  modified  from  this  page  like  for
example the products shown per page and
the  categories  menu  type  (standard  or
template  based).  Please  refer  to  the
Templates  manual  for  more  information
about the template based menus. 

Products -> Search 

 

iBoutique.MALL  offers  the  possibility  for
the  administrator  to  define  which  of  the
basic  product  fields  are  searchable.
Currently  the  fields  in which  the website
visitors  and  clients  could  search  are  the
product name, short and long descriptions.
In  order  to  deactivate  for  example  the
search in the product's long description the
administrator  needs  to  uncheck  the
correspondent check box. 
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Orders -> Approve 

 

The  page  provides  functionality  for  the
administrator  to  approve  orders.  Please
refer to the Orders manual in order to see
the  different  order  status  and  more
information on the orders validation. 

Orders -> Full List 

 

On the "Full  List"  page,  the administrator
can see all the orders placed on his website
with detailed information for the items in
this  orders,  billing  and  shipping
information. 
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Orders -> Payment Settings 

 

iBoutique.MALL  comes  with  several
payment  systems  integrated  by  default.
The  file  /extensions/order.php  should  be
modified  in  order  to  add  new  payment
systems. Please don't hesitate to contact us
if you are interested in integrating an other
payment solution. 

Orders -> Invoice Settings 

 

The  page  offers  the  possibility  for  the
administrator  to  modify  some  general
invoice settings such as the company name
or  the  invoice  footer  information.  The
administrator can generate an invoice in .
pdf format for a selected order by clicking
on  the  pdf  icon  located  on  the
corresponding order line. 

Iboutique.MALL, a product of NetArt Media www.netartmedia.net



Website -> Management 

 

iBoutique.MALL is powered by a limited in
functionality version of WebSiteAdmin. The
website -> management page is one of the
websiteadmin  structure  and  content
management  related  pages  providing  the
possibility  to  freely  edit  the  website
structure (add/remove pages) and content
(using  WYSIWYG  editor  or  directly
modifying the page html). 

This  page  provides  functionality  to  the
store  administrators  to  manage  their
websites structure with simple mouse drag-
and-drop movements. For example to add a
new page the administrator has to drag the
icon for new page to the desired position. 

Website -> Management Pro

 

The  Management  Pro  is  by  default
accessible  only  to  the  members  of  the
Administrators  group.  It  provides  more
functionalities  for  the  website  structure
and content management compared to the
basic drag-and-drop management page. In
order to edit the settings of a page (such as
its title, meta tags etc.) one should select
the  page  appearing  in  the  site  structure
tree with a left mouse click. After that one
needs to click with the right mouse of the
button  and  a  new  context  menu  will
appear with multiple options. 
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Website -> Navigation Menu 

 

WebSiteAdmin offers  flexible functionality
for handling the main front site navigation
menu. There are 2 main types of navigation
menus in WebSiteAdmin: 
-  Customized  (it's  possible  with  them  to
enter  a  template  which  will  be  used  for
every link or enter arbitrary html code or
image which will  be shown for the page's
link) 
-Standard  (these  menus  are  generated
automatically  according  to  the  website
structure  defined  by  the  administrator  -
they are multilevel  and the  administrator
can  fully  customize  their  colors  and
appearance from the Settings link on this
page) 

Templates -> Select a Template 

 

The  page  offers  the  possibility  to  the
administrator  to  select  a  template  which
will be used for the front site between the
currently available templates. Please note
that  in  order  to  be  able  to  select  a
template  for  a  given  website,  the
administrator  needs  to  add  first  the
template (if it doesn't still exist) 
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Templates -> Add a New Template 

 

This  page  can  be  used  to  add  new
templates  to  the  website.  The
administrator  have  a  choice  to  choose
between  the  option  to  add the  template
using  the  WYSIWYG  templates  editor
(which  produces  simple  template)  or  to
directly paste the template html code. 

Templates -> Modify 

 

On this page the administrator can see the
available templates and modify a selected
template. In order to select a template for
modification, the administrator should click
on the  Modify  icon  and  then  a  new text
area  having  the  full  template  code  will
appear. 
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Extensions -> Extension Files 

 

The extensions and custom tags, provide an
universal way to expand the WebSiteAdmin
functionality.  The  so  called  extensions
represent  regular  php  files  which  output
html  code.  So  one  could  create  a  new
extension  just  as  writing  a  standard  php
file. In order to set this file to be executed
on a selected page (and the correspondent
content to be rendered) the administrator
needs to go to Website->Management, then
select a page with a left mouse click and
then right  click  and a new context  menu
will appear having the different options. 

Extensions -> Custom Tags 

 

The difference between a custom tag and
an extension is that a custom tag can be
plugged  in  the  template's  code  and  then
set some extension file to be executed for
it. In such way, every time the system finds
such a custom tag in the template's html, it
will execute the extension file and replace
the associated tag with html rendered by
the extension file. 
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Tools -> Image Manager 

 

The  image  manager  could  be  useful  for
quick review of the available images on the
website  (including  these  uploaded  by the
users for the car ads). The administrator is
able  to  delete  some of  the  images  if  he
wishes. 

Tools -> New Form 

 

The custom server side forms functionality
is  a  standard  WebSiteAdmin  feature
allowing  the  administrator  to  create  and
publish  on  the  front  site  forms  (such  as
contact forms) with custom fields defined
by the administrator. Adding a new custom
server side form can be done on 2 steps -
the first one is to enter the form name and
a brief description and the second one is to
add  the  form  fields.  For  every  field  the
administrator  should  specify  its  name,
type,  the  text  displayed  near  it,  its  size
and if it's an obligatory field (available only
for  some  of  the  fields)  and  the  message
which will show up if the user leaves empty
an obligatory field. 
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Tools -> Manage the Forms 

 

This page provides functionality to manage
the existing custom server side forms. One
can  assign  a  form  on  a  page  as  well  as
modify the form settings - such as message
that will be displayed to the user when he
submits the form as well  as the email  to
which  the  data  will  be  sent  and  a  few
others. 
The "Posted Data" can be used to view the
posted data by the users from the custom
server side forms published on the website.
Please  note  that  if  the  administrator  has
defined also an email to which the posted
data should be sent, it will be sent to the
email and it will appear on this page. 

Statistics -> Reports 

 

The  administrator  can  see  multiple
statistics  info  from  the  pages  from  the
Statistics  category  in  the  back  office.  He
could also find pages allowing to check the
Google registration status of the pages of
the  website  as  well  as  submit  them  in
Google  and  a  few  other  popular  search
engines. 
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Security -> User Groups 

 

The office offers the possibility to create
different back office user groups and users
in them and assign different permissions to
access the pages in the back office. These
groups and the associated permission sets
can be used after that when creating the
store packages. 

Security -> Permissions 

 

The  Security->Permissions  can be used  to
modify the permissions for a selected user
group. The main administrator has to check
the  checkboxes  of  the  pages  that  the
members from this group will be allowed to
access. 
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Settings -> Language Versions 

 

By default, the iBoutique.MALL solution is
multilanguage  and  can  support  multiple
languages. On this page the administrator
can  add  a  new  language  version  or
deactivate  some  of  the  current  ones.
Please  note  that  when  adding  a  new
language  version,  one  needs  also  to
translate  and  add  the  corresponding
language file for it. 

Settings -> Languages Menu 

 

If  the  website  is  multilanguage  and  a
languages menu has to be displayed on the
front  site,  this  page  can  be  used  to
customize this menu. The standard menu is
composed by flags - one needs to click on
the corresponding flag to switch between
the  different  language  versions.  The
customized  menu offers  the  possibility  to
enter  arbitrary  code  for  every  language
menu item. So the administrator has in this
way the possibility to enter other images or
whatever html code (it can be for example
the name of the language version etc.) 
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Settings -> Website Style 

 

From  this  page  the  administrator  can
change some general website style settings
such as the default font color, the default
links  color  etc.  If  the  first  field  on  this
page  "Disable  these  styles"  is  set  to  YES,
the styles set on this page won't apply for
the website.
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