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1. Installing the website

You may find below information about the Jobs Portal integrated setup wizard, the description of the
different steps during the installation, possible errors and troubleshooting information. 

The setup is quick and easy, it passes through just 3 steps – agreeing with the license agreement,
entering the MySQL information (server, username and password) and selecting the database to be
used for the installation.

Please note also that we offer a free installation for all our products, so if  you prefer that we do it for
you, please contact us and we'll do it asap after that on your server or hosting package.

Step 1 - Welcome screen and Jobs Portal end user license agreement

In this first step you'll be able to:
 see the  setup welcome message
 read the Jobs Portal end user license agreement

In order to continue to the next  step, you'll  have to  agree with the Jobs Portal  end user license
agreement by clicking on the check box (“I agree ...”).

Step 2 – Entering the MySQL server information (MySQL server, username and password)

During this step you'll be able to enter the MySQL server information (the server name, MySQL user
and password) of your host. The setup needs this information in order to be able to setup  the main
database used by the Jobs Portal setup. 
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In this step, you'll be asked to enter:

- MySQL Server – the server where you plan to install the database, usually “localhost” for most of the
hosting companies 

Please note that on some hosting companies like GoDaddy, the MySQL server name is specific for
every database, which is created and looks like for example: db_name.db.11111.hostedresource.com
In such cases it's necessary to copy and paste the exact server name, which you may find in the
hosting package control panel and the Databases tab

-MySQL username and password 

On most hosting package, you'll need first to create a new MySQL user and database from the hosting
package control panel, so it's up to you to choose the password and username you prefer. 

Please note on cPanel hosting package (used by the most popular hosting companies like HostGator,
BlueHost, HostMonster, GoDaddy Hosting etc.) if you create a new database and MySQL User you
need to explicitly give permissions to this user for the database you created – you can do that from the
MySQL Database page in cPanel, at the bottom.

If you are not sure for these settings, please contact your hosting provider or log in to your hosting
package control panel,  where usually this information can be found on a page called “MySQL” or
“Databases”.

After you enter these values and click on the Continue button, the setup will try to connect to the
MySQL server with the user name and password you entered. If  any of values aren't correct (the

Jobs Portal is a product of NetArt Media  www.netartmedia.net , All rights reserved

http://www.netartmedia.net/


address of the MySQL server or the MySQL user name and password), then an error message will be
displayed and you won't be able to continue until you enter the correct values.

Troubleshooting

1. After you click the Continue button you receive an error message in red saying “Server doesn't
exist or access is denied”.

If this is the case, please check again the values you have entered. If the problem persists: 
– make sure that your MySQL server is up and running and that this account is valid
– make sure also you enter a correct MySQL server name (on companies like GoDaddy and 1&1
the name isn't the default “localhost” and may be different for every database) 
– on cPanel hosting packages, please check if permissions for the database are granted to the
MySQL user you entered
- if you have any troubles finding the correct MySQL information for your hosting package, you
can also  contact your hosting provider and ask them for the MySQL settings for your hosting
account

Step 3  - Setup of the main Jobs Portal database

In this step you'll  be asked if  you would like to create a new database for Jobs Portal or use an
existing one. 

If you choose the option to create a new database, you'll be asked to enter the name of the database.
We recommend you to use a name, which will be easy to distinguish, like for example jobs_portal . Be
aware that when choosing this option, the MySQL user you have provided in the previous step should
have the rights to create new databases on the MySQL server. If this is not the case, the database
creation will fail and such error will be displayed on the screen.
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If you choose the option to use an existent database, the Jobs Portal database tables will be created
in the database chosen by you. All the tables, which will be created will have a prefix “atn_”, no data
from the existing database and tables will be deleted. 

Troubleshooting
1. I have  chosen the option to create a new database but when I click on Continue, I get an error

message colored in red and I can't proceed to the next step, why?
- make sure that your MySQL user has “CREATE DATABASE” permissions on the MySQL server
- make sure that you don't have already a database on your server with the same name as the one
you entered

2. I have tried to use the second option, to use an existing database, but I receive an error message
saying that the table “jobs_admin_users” already exists
- this means that you have previously installed the script in this database, so you may either use a
new database or delete the old script tables and then continue with the installation

Be aware that in this step the setup creates also the script configuration file. If the process running
PHP on your server for your hosting package doesn't have right permissions in the folder where you
install Jobs Portal you'll receive the following message in the interface:

The  process  running  PHP  on  this  computer  doesn't  have  permissions  to  create  and  write  the
configuration file in the main web folder. You need to create it manually – the content will show up in
the screen. You need to copy / paste it in a file “config.php” and upload it in the main web folder (the
one in which you uploaded the real estate files). So you could either upload it with FTP or use the File
Manager in your hosting package control panel to save the config.php file.

If you experience troubles when doing this or have any additional questions, please don't hesitate to 
contact us or request our free installation service.

Step 4 – Installation successful screen

If you reached this step, Jobs Portal has been installed successfully on your server/hosting package
and you can open now the front site and also the administration panel to manage the website and
different settings.

2. Configuring the website

The Settings category in the administration panel and the different pages and options there allows you
to configure the website and the different options like the job listings expiration time, currency, time
zone, payment options, job categories, locations and others. You may find below a list and description
of the different configuration options available on the settings page.

The Settings category contains the following pages:

– Configuration Options (on which you may find and set the general website configuration 
options)
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– Job Categories (where you can modify the main website job categories)

– Locations (from where you can change the job locations used when searching or posting jobs)

– Course Categories (allowing to set the categories to be used when posting course listings on 
the site)

– Job Feeds (allowing to set the different job feeds to be used on the sitelike Indeed, 
SimplyHired and CareerJet etc.)

– Banners (allowing to create and configure special banner spaces in which the users can 
upload banners)

– Field Values (modify the possible values of the job seeker fields)

– Ads & Analytics (allowing to add Google AdSense or other 3rd party advertisements on the site 
or Google Analytics tracking code)

– GDPR (on which you can enable the GDPR consent message – ask permissions from the 
users for setting cookies and storing his personal information to comply with EU data privacy 
rules or other GDPR related settings)

2.1. Configuration options

The Configuration Options page allows to change the basic settings like the system email address,
URL format and others. Please find below information about the different settings and configuration
options shown on this page.
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Facebook Page URL, Twitter Page URL, Linked In Page URL, YouTube Page URL, Instagram
Page URL
In these fields you can enter the URLs of your Facebook, Twitter and others social media pages,
which will show then as clickable icons / links in the Connect With Us section on the website located in
the footer.

Jobs Expire Time (Days)
With this setting you can set the number of days in which the job listings posted on the website will
expire. The default value is 30 (meaning the posted ads will expire in 30 days), but you can change it
with any other number of days you may wish.
If you set it to: -1 , then the job ads posted on the website will never expire.

Allow not registered users to apply for jobs
If you set this setting to YES, it will allow also not registered job seeker users on the site to apply for
jobs. The default value is NO, meaning that the users should register first before applying for jobs.

Manually approve the new employers
This setting allows to configure if the newly registered employers / companies will have their accounts
activated automatically (and be able to directly log in and post jobs) or a manual validation from the
administrator will be required for that. The employer accounts can be validated / activated from the
Users → Employers page in the admin panel by changing the value of  the “Active” column for  a
selected job seeker. 

Manually approve the new jobs
If  this setting is set  to YES, then all  posted jobs on the website will  have to be validated by the
administrator in order to show up on the website and search results.
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Enable SEO URLs
The search engines optimized URLs look like static HTML pages and have keywords in the URL,
which allows better indexing by search engines like Google.
In order to use the SEO links, it's necessary to have mod_rewrite enabled (nearly all Linux shared
hosting packages available on the web have it enabled by default)  or isapi_rewrite for Windows / IIS
hosting server. If this module is not available on your server or hosting package, you could deactivate
this feature by setting it to NO.

System Email Address
This field allows to change the email address that will appear as a sender of the emails sent by the
website to the users. Please note that most hosting companies require a sender email using the same
domain name. For example if  your website is installed on domain.com, the system email address
should be user@domain.com and not for example some.name@yahoo.com (in such a case the server
may refuse to send the email, depending on what's configured by the hosting company).
If you would like to use an email address of an external email provider, there is also functionality to
configure an external SMTP server (that can be gmail or any other email provider supporting sending
emails through SMTP).

System Email From Field
The name of the sender of the system email address, usually your website name or company name.

Send email to new users
If set to YES, then welcome emails will be sent to the new users registering on the website.

New employer user email subject, New employer user email text
If you set the website to send welcome emails to the users, in these two fields you can enter  the
subject and text of the welcome emails, that will be sent to the new employer users.

Number of results per page
By changing the value of this setting, you can control how many listings will show up on the job result
pages  that  appear  after  an  user  makes a  search  or  browse  the  jobs  by  category,  location  or  a
keyword.
The default value is set to 20, meaning that 20 jobs will be shown per page and you can change that
to any other number of jobs you prefer.

Date hour format
By entering a valid PHP date format string, you can change the format of the date displayed on the
website and different pages on it.

The default format is - 

d/m/y G:i

which will show the date on the website like - 

03/10/2021 11:52h

When configuring the date format, you can use any valid PHP date format strings or form your own
format strings by using any of the special letters - 

d Day of the month, 2 digits with leading zeros
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01 to 31

D A textual representation of a day, three letters
Mon through Sun

j Day of the month without leading zeros
1 to 31

N ISO-8601 numeric representation of the day of the week
1 (for Monday) through 7 (for Sunday)

w Numeric representation of the day of the week
0 (for Sunday) through 6 (for Saturday)

F A full textual representation of a month, such as January or March
January through December

m Numeric representation of a month, with leading zeros
01 through 12

M A short textual representation of a month, three letters
Jan through Dec

n Numeric representation of a month, without leading zeros
1 through 12

Y A full numeric representation of a year, 4 digits
Examples: 2014 or 2022

y A two digit representation of a year
Examples: 14 or 22

g 12-hour format of an hour without leading zeros
1 through 12

G 24-hour format of an hour without leading zeros
0 through 23

h 12-hour format of an hour with leading zeros
01 through 12

H 24-hour format of an hour with leading zeros
00 through 23

Here are a few examples:

F j, Y, g:i a which will display the date on the website like: March 10, 2021, 5:16 pm 

m.d.y which will display the date on the website like:  03.10.21

Y-m-d H:i:s which will display the date on the website like:  2001-03-10 17:16:18
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Number of listings in Featured section
You can use this setting to set the number of featured jobs that will show up in the Featured Listings
section to the right or the home page of the website (if featured jobs are set to show below the main
search form in the home page configuration options). 

New job seeker user email subject, New job seeker user email text
If you set the website to send welcome emails to the users, using these settings you can set the title
and text of the welcome emails that will be sent to the new job seeker users.

Use CAPTCHA images to prevent spamming
To avoid automatic form submissions when creating a web form it's necessary to use a verification if
the site visitor is a human or a robot – the most common way to do it is to generate an image with a
random code that the users will have to enter, called also captcha. What it does is to dynamically
create an image with a  string displayed on it – the visitor is asked to type that string in a text field and
once the form is submitted it checks if the string on the image matches the one inputted by the user.
The usage of the captcha images is enabled by default, but if you would like to disable it (for example
if the PHP graphics library - GD isn't installed on your website), you could change the value of this set-
ting to “NO”.
There is also functionality to use the Google's reCaptcha (“I am not a robot” checkbox), which offers
stronger anti-spam protection and can be configured using the settings below.

Website time zone
With this setting you can change the default time zone on the website that is used to display the time.
The time zone coming by default for most of the downloads is Europe/London, but can be replaced by
America/New_York or another appropriate time zone.

The list of the supported time zones can be found on: https://www.php.net/manual/en/timezones.php

Some examples of supported time zones are: 

America/Buenos_Aires
America/Chicago
America/Los_Angeles 
America/Mexico_City 
America/New_York 
Asia/Singapore 
Asia/Tokyo 
Europe/Berlin 
Europe/Madrid 
Europe/Moscow
Europe/Zurich
…

SEO text to be appended to the job category page title
When clicking on a category, the default page title (the HTML <title> tag that is used also by search
engines when indexing the page etc.) will be the category name. By adding custom text in this field,
you can customize the titles of the category pages, which will be then the Category Title + Your Text
(so in this way you can create unique titles for better search engines optimization).
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SEO text to be appended to the job category page meta description 
By adding a text  in  this  field,  you can add a text,  which will  be append- ed to the default  meta
description for SEO purposes.

SEO text to be appended to the job category meta keywords
By adding a text  in  this  field,  you can add a text,  which will  be append- ed to the default  meta
keywords for SEO purposes.

Show number of jobs in category
If set to YES, will show the number of posted jobs in the category like  for example Category Name
(15). Please note that when the website is configured to use job feeds like indeed, except the jobs
posted on the website, when clicking on a category the users will see also the jobs provided by indeed
– in this case the number of jobs shown for the category will be only the number of  jobs posted on the
website itself  (not total jobs, which will be taken from indeed.com etc.).

Partner Companies 
In this field the administrator can enter a list of usernames / email addresses of partner companies
that can post jobs on the website without making payments. 

Allow Multiple Job Categories 
If this setting is set to YES, then when posting a job, the employers will be able to select up to three
job categories for their jobs instead of one.

Delete expired jobs 
By default the jobs posted on the website expire after some number of days (according to what's set
by the administrator on this page and field above) and then they don't show up anymore on the main
site or search results, but just on the Expired Listings page in the employer admin, so they can choose
to renew them by paying a fee. This option makes it possible also to permanently delete the expired
job ads after a period specified by administrator by choosing between one of the following options:
Never
After 1 month
After 3 months
After 6 months
After 12 months

Use external SMTP server, SMTP server URL, SMTP username / email address, ...
By default to send the emails, the script is using the local mail server, but in some cases or on some
hosting package the usage of the mail function may be disabled, so it may be necessary to use an
external server like gmail or similar to send the emails.
With these settings you can enable the usage of an external smtp server and set the different settings
for it like the server URL, smtp user (this is typically your registered email address there), password
etc.

Salary range 
This setting allows to customize the Salary preference field and values shown in it by entering new
custom values. The different values should be separated by: |    like shown below:

1000|2000|3000|4000|5000|6000|7000|8000|9000|10000|12000|14000|16000|18000|20000|25000|
30000|40000|50000|60000|70000|80000|90000|100000
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Google Maps API Key
Since June 2018, Google requires all sites using Google Maps to have a valid Google Maps API key.
To  set  your  own  key,  you  need  to  go  the  page  for  getting  a  maps  key  (the  current  url  is:
https://cloud.google.com/maps-platform/#get-started but you may also find it with Google by searching
for: get google maps API key  and click on the first link) and then set it in this field on the Configuration
Options page

Show an under construction / maintenance page
When you set this value to YES, the visitors visiting your website will see an under maintenance page
instead of the actual site (so you may use it when doing updates or if you prefer to still not launch your
site etc.).  
Please note that if you are logged in as administrator in the admin panel and visit the main site, you'll
be still able to see it (so you'll see the actual site and not the under construction page even if the
construction page is enabled) – this is done in order to allow you to still work or check the site while
others see the under construction page.

Under construction / maintenance page title, Under construction / maintenance page text
With these fields you can edit the under construction page content and set the under construction
page title and text 

Enable ZIP field, Enable ZIP distance search
These options allow to show or hide the ZIP field and ZIP distance search (available by default for the
US and UK on request). For other countries these options may be turned off or just the ZIP field to be
left (it can be renamed also to Post Code or other field name in the language file).

Maximum number of files
The field allows to limit the maximum number of files that the job seeker users will  be allowed to
upload on the site (like resumes, cover letters, references etc.).
 
Maximum file size (bytes)
In order to save space on the server / hosting package, it's possible to set the maximum allowed file
size by setting the size in bytes in this field

Enable Google reCaptcha, reCaptha Public Key, reCaptcha Private Key
The Google's reCaptcha offers a strong anti spam protection and is also used by some of the most
popular websites like Google, Facebook, Twitter etc. 
If you would like to enable Google reCaptcha on your site, you need to first create your free account
on  https://www.google.com/recaptcha and public and private keys for your site, which you can then
paste in the corresponding fields and set the value of Enable Google reCaptcha to YES
The default value is NO, meaning that the default captcha image in the software will be used.

Number of free jobs for the new employers
This setting allows to configure a number of free jobs every new employer can post for free after
registering on the site. The default value is 0 meaning that they won't get any free jobs, but if it's set
for example to: 2 , then every new employer will get 2 free jobs before being asked to make a payment
(purchase a job posting package or a subscription etc. , depending on the payment options set by the
administrator).
 
New Users Email Validation on Sign up
If set to YES, the new users signing up on the site (job seekers or employers) will receive an activation
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link to their email addresses – they will have to click on the link in order to confirm their email address
and activate their account.
 
Main Search Field Suggestions
When typing in the text search field in the main search form, the users see text search suggestions –
with this setting the administrator can set the type of suggestions they see. There is a choice between:

– None (no suggestions will show up at all)
– Jobs By Keyword (the administrator can enter a list of keywords that will show as suggestions)
– Job Categories (the suggestions will be from the existing job categories and sub categories)
– Keywords + Job Categories (a mix between both options above)

 
Show number of visits for jobs
YESA statistics is kept in the database about how many times a job offer has been visited on the main
site – if this setting is set to YES, then the users will also see on the job details page the number of
visits
 
Message Subject, Message Text, Employers Message Subject, Employers Message Text
If the system is configured to send activation / welcome emails to the new users, then with these fields
the administrator can customize the subject and text of the messages that are sent to the users.
In the text of the email, the default  [ACTIVATE_LINK] will be replaced with the real activation link
generated by the system. The rest of the text can be customized and more text can be added with the
only requirements being to keep   [ACTIVATE_LINK] in the text of the email because otherwise no
activation link will be present to the users.
 
Welcome to domain.com!

Please click on the following link in order to activate your account:
 [ACTIVATE_LINK]
 
The fields are separated for the job seekers and employers in order to allow to set different email
subjects or texts for them.
 
Send Feed Email Alerts
The functionality to send email alerts for the jobs posted on the website is enabled by default. This
additional setting allows also to configure email alerts to be sent for jobs received by job email APIs.
 
Email Alert Title, Email Alert Text
These two fields allow to customize the subjects and texts of the email messages sent to the users
when there are new jobs posted on the website matching their search criteria. 
In the text of the email, [FIRST_NAME] will be replaced by the user's first name and [JOBS_LINK] with
the actual job link on the site allowing to see the full job details.

Dear [FIRST_NAME],

Please find a selection of latest jobs matching your search criteria:

[JOBS_LINK]

2.2.   Setting the payments and payment options
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You can choose between 4 main methods to charge the employers:

– Based on credits (the users buy credits and then spend them to pay to pay for the different
services on the website)

– Based on subscriptions (the employers can choose a subscription and pay then for example a
monthly fee and be able to list up to some number of jobs)

– Direct payment (as soon as the employer posts the job, he sees for example a PayPal icon) or
alternatively choose the website to be free for all users and in such case the users won’t be
charged when posting jobs or using the other services offered on the website

– Job Listing  Packages (you can create  packages including different  number  of  job  listings,
featured listings and resume views and let the employers purchase these packages and use
them after to post jobs etc.)

The administrator is able to select one between these 4 types he prefers from on the Payments →
Settings page in the admin panel.

The page allows to charge the configuration options related to payments (you may find below a list
with explanations) and also links to pages for creating or managing the existing subscriptions or set
the price in credits for the different services used on the website.

How you would like to charge the employers?
Using this  setting  you can set  your  preferences if  you would  like to charge the employers  using
subscription or using credits or if the site should be free for all users. If you choose to charge them
with subscriptions (recurring payments), you can create different subscription packages with different
number of ads, featured ads and banners included in them and different pricing and let the users
choose the subscription they prefer.  If  using the credits method,  the employers need to purchase
credits and they can spend after these credits to pay for the different services offered on the website.
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Website currency
By default this setting is set to the US dollar sign “$”, but you may change it to another one you prefer
(like CHF or €).  This will change the currency symbol displayed next to the prices on the website.
This applies for all the prices of the listings on the website, pricing for posting listings and banners etc. 

 
Currency Code 
The PayPal currency code if the PayPal system is enabled. By default it's set to USD (US dollars), but
can be changed to any other valid PayPal currency code like EUR, GBP etc.

You may find below the currency codes for some of the most popular currencies supported by PayPal:

Australian Dollar AUD 
Brazilian Real BRL 
Canadian Dollar CAD
Czech Koruna CZK 
Danish Krone DKK 
Euro EUR
Malaysian Ringgit MYR 
Hong Kong Dollar HKD 
Mexican Peso MXN 
Norwegian Krone NOK 
New Zealand Dollar NZD 
Philippine Peso PHP
Polish Zloty PLN 
Singapore Dollar SGD 
Swedish Krona SEK 
Swiss Franc CHF
Thai Baht THB
U.S. Dollar USD

 
PayPal ID 
When the PayPal system is enabled, in this field, the administrator/website owner has to enter the
PayPal account (registered PayPal email address) he would like to use to charge the users on the
website.

 
2checkout ID 
When the 2checkout system is enabled, in this field, the administrator/website owner has to enter the
2checkout SID  (Seller ID) of the 2checkout account he would like to use to charge the users on the
website. The seller id can be obtained from the 2checkout website (during a new registration for the
new users) or from the admin panel for the registered ones.

 
Cheques address 
In this field the administrator has to enter the address, which has to be used for the cheques to be
sent if the cheques payment options is enabled on the website.

 
Bank account information 
In this field the administrator has to enter the full information for the bank account to be to be used
when the bank transfer payment option is enabled on the website.

 
Amazon Payments ID, PayFast ID, InterKassa ID, Google Checkout ID, Skrill/Moneybookers ID ,
PayMate ID
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To enable any of the following system in order to charge the users, it's enable to enter your ID for them
in the corresponding text fields on the Configuration Options pages.
If you wish to disable any the systems in the future, it's necessary to simply delete the corresponding
ID.
 

2.3. Job and course categories

You can set the job categories from the Jobs → Job Categories page in the admin panel and the
courses one from Jobs → Course Categories

The job categories should be set as a list with leading numbers show- ing their hierarchy, for example:

1. Some Main Category
1.1. Sub Category of the Main Category
1.2. Another Sub Category of the Main Category
...
2. Another Main Category
...

It's not required that the numbers are in successive order, so it can be possible for example to have -

1. First Category
49. Second Category
3. Third Category

If you have more than one language added on the website, you'll see separate text areas allowing to
enter separately the categories for the different languages on the site.
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If you would like to add a custom image for a category, you can click on the category name to the right
– this will open a page allowing you to upload a new image or edit or delete the existing ones.
The categories with images added for them will show up on top of the Browse by Category section on
the Home page of the main site.

2.4. Modifying the locations

Similar to the job categories, the locations can be set from the Jobs → Locations page as a list with
leading numbers showing their hierarchy. By default up to four levels of lo- cations as supported, so
you may have for example Country – State – City – Neighborhood.

You can also upload custom images for  selected locations similar  to the categories as explained
above by clicking on the location name to the right and uploading the image.

2.5. Changing the default field values

The page Settings → Field Values allows to set the values of some of the basic fields available for the
job seekers to create their resume or set their job preferences.

Please note that when setting the new values, you can use words from the language file or enter the
value  in  plain  text,  for  example  if  you  use  M_FULL_TIME  the  system  will  search  for  the  word
M_FULL_TIME in the language file (for example include/texts_en.php for the default English language
with M_FULL_TIME set to “Full Time” there) and will display Full Time.

If you don't use multiple languages on your website, instead of using words from the language file you
may simply enter the text “Full Time”.
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2.6. Configuring the job feed usage

Using the Settings → Job Feeds page, you can configure the different job feeds used on the website.
You can choose between displaying one main feed (like for example to show only indeed jobs on the
site) or to mix and show different feeds. Please note that all these systems require that you first sign
up with them, get a partner ID that you can set on this page in order to activate the feed on the site
and start displaying jobs.

You  may find  more information  about  the  different  partner  programs and  their  conditions  on the
respective  sites  of  the  companies.  For  ex-  ample  for  indeed,  please  visit
http://www.indeed.com/publisher and to create an account  please click on the big blue Create an
Account button there, as shown on the screen shot below:
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2.7. Configuring the banner zones on the website

The Banner Areas functionality allows the administrator to create special banner zones / banner areas
in which the employers can upload their banner for a fee.

There are no limitations for the number of the different banner areas the administrator can create and
for every banner area, he can set the banner width and height, position and price.
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When adding a new banner area, the administrator has to enter its name and description, the banner
area position (there is a choose be- tween Side Column - the banners will be displayed in the side /
right column of the site, Top and Bottom), number of rows and columns (if setting for example 2 rows
X 6 columns, the banner are will be able to display up to 12 banners in 2 rows and 6 columns), width
and height (the width and height of the individual banners added in that area) and the number of days
in which the banners added in this area will expire.

3. Administration panel

When creating the software, we strove to design and create an administration panel, which is as user 
friendly as possible and gives quick access to all the settings and ads management pages.
The administration panel is responsive and mobile friendly (adapting to the different screen sizes) and 
is also using tiles to make easier working with it when using touchscreens. 

3.1. General overview

The administration panel is the main tool available for the Jobs Portal website administrator to manage
the website, change its settings, pages content etc.

The features in the admin panel are divided in categories. The main administrator and the members of
the Administrators group have access to all the categories and pages in them. 

The Jobs Portal administration panel functionality is divided in 8 categories / menus in the main start 
menu: 
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- Home (welcome / dashboard page, modification of password, log in report) 
- Jobs (management of the job listings, applications, job alerts and others) 
- Users (employers and job seekers management, adding custom fields for the users)
- Website (front site structure and content management, navigation menu settings) 
- Settings (management of the locations, configuration options and others) 
- Payments (allowing to configure the payment options on the site)
- Extensions (custom extensions and extension files and different modules) 
- Templates (front site templates management) 
- Statistics (reports and referrals for the website visits) 
- Admin Users (management of the administration panel users, groups and permissions) 

3.2. Main pages in the administration panel

You may find below a quick overview and brief information about the most used pages in the 
administration panel and functionality on it.

Home → Welcome

The Welcome page in  the administration  panel  provides  quick information about  the new listings
waiting to the approved and statistics, as well as links to the main pages in the administration panel for
easier navigation.
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Home → Log in Report

The log in report shows a log of the administration panel log in attempts – the successful and failed log
ins with their date and IP address.

Home → Change Password

This page can be used to change the password of the user for the administration panel. To change the
password  it's  necessary  to  enter  the  old  password  and  the  new one  and  confirm  it  –  after  the
password is changed successfully, the user will be logged out and asked to log in again with his new
password.

Jobs → Job Listings

The page allows to see the jobs posted by the users, modify or delete them.
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Jobs → New Job Ad

Using this page, the administrator is able to post a job for a selected employer.

Jobs → User Messages

The page allows to see the messages exchanged by the users and moderate them.

Jobs → Job Alerts

The Job Alerts functionality can be used by the job seeker to create email alerts and be notified by 
email when a new job meeting their search criteria is posted on the website.
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Jobs → Fields

Using the functionality on this page, the administrator can add new custom fields for the job ads – 
these new fields will show up then on the forms for posting new jobs and also on the main site when 
seeing the job details.

Jobs → Applications

The page allows the administrator to monitor the job applications for the different jobs posted on the 
website.

Jobs → Uploaded Files

On this page, the administrator can see the files uploaded by the job seekers and also download any 
of them if he prefers so.
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Users → Employers

The page allows the administrator to monitor the employers and re- cruiting companies registered on 
the website and modify their profile information.

Users → Job seekers

The page shows a list of the registered job seekers on the website with links allowing to modify their 
information and see their resume.
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Users → Job seeker Fields

Except of adding custom fields for the job ads, the administrator is  also able to add custom fields for 
the job seekers – the new fields will show up on the job seekers registration page and also on the 
page in the job seekers admin allowing them to change their profile information.

Users → Employer Fields

The page makes possible for the administrator to add custom fields for the employers / recruiting 
companies signing up on the website.

Settings → Configuration Options, Payments, Job Categories, Locations, Banner Areas, Field 
Values, Job Feeds, Course Categories

The page has many different options that you can use to configure    your website in the way you 
prefer – set your timezone and currency, configure the preferred payment options and many others. 
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Please find detailed description of the different settings in “2. Configuring the website”

Website → Pages

This is the main page to be used to manage the website structure and content – add new pages, 
remove or rename the current ones, modify the pages content, the page title meta keywords or meta 
description   or set custom php extension to be executed for a page.

Website → Logo & Colors

On this page the administrator can change the website logo – upload it as an image or enter it as text 
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and enter a different accent color on the website or select a background image.

Website → Home Slider

The page allows to manage the settings of the slider displayed on the home page of the main site – 
choose if featured or latest jobs should show in it, own slides or a mix between them. It's possible also 
to edit the background images used for the slides and enter for every slide the title, text and link.
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Website → News

The page allows the administrator to post news on the site, which will show up after on the News page
on the main site and in the latest news section in the footer.

Website → Language Versions

If you would like to run a multi-language website, it's necessary to add the additional languages from 
this page in the administration panel. Please note when you a add a new language, it's necessary to 
upload also the language file for it in the /include folder on your website. Please refer to the 
“Languages and language files” for more information and description of the language files and 
languages management.

Extensions → Files

The page shows the current files in the /extensions folder, which can be used for extensions of the 
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pages or custom tags. Please note that files that should be used for custom tags have _tag at the end 
of their name. A file can be set to be executed as extension for a page from the Website → 
Management page and for a tag from Extensions → Tags

Extensions → Tags

You can use this page to see the current tags, delete any of them or add new tag. Please check the 
chapter “Custom Tags” to read more about their usage and functionality.

Extensions → FAQ Manager, Extensions → Newsletter

These are some basic modules loaded by default from sour site man- ager content system allowing to 
post news on the website, create a page with frequently asked questions and send newsletter to the 
users who have subscribed for it.

Templates → Modify, Templates-> Select a Template, Templates → Add a New Template

These pages can be used to modify the front site template, select a dif- ferent template or add a new 
template by pasting its HTML code.

For more information about the templates and their structure, please check the section “Templates 
Management' in this manual.

Statistics → Reports

The page shows brief information about the website visits and also displays a chart for them.

Please note that the integrated website visits tracking and statistics in- formation is basic and simple, 
for more advanced tracking and information, we recommend using an external system such as Google
Analytics, which can be easily added on the website.
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Statistics → Referrals

You can see on this page the last referrals, so you can easily track who is linking to your website and 
from where the traffic to your website comes from.

Users → User Groups, Users → New User, Users → User Permissions

Using these pages, you can add new administrator users to your web- site, put them in groups and set
their permissions. This can be useful if you would like to have multiple users working on the website 
with permissions limited to just some selected pages. For example have a News Administrators group 
with permissions to access only the News Management functionality in the administration panel etc.

4. Website structure and content management

The functionality, different menus and options on the Website → Management page allow the 
administrator to manage the website structure – add new pages, rename or remove the existing ones 
etc. and also manage the content of the website, edit the content of the different pages, set extensions
to be executed for them and others.

4.1. Structure management, adding new pages
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Changing the front site pages meta title and description

In order to change the front site pages meta title, keywords or description, the administrator has to log
in in the admin panel and go to the Website->Management page. 
On this page, he will see the available website pages as a tree. He  has to left click with the mouse on
a page in  order  to  select  it  and then choose from the Context  menu which will  show up “Page
Settings”.

A new page will show up containing various page fields including also the page meta title description.
The administrator has to enter the new values and click Save.

Adding new pages to the website

The Jobs Portal admin panel offers  the possibility to freely edit the website structure – add, edit or
delete the pages  of the front site.

Please  note  that  you  need  to  define  the  website  structure  separately  for  the  different  language
versions available (you could switch between the language versions by selecting the language from
the big drop down menu at the top of the Website → Management page).
In order to add a new page to the front site you need to click on the New Page button at the top of
Website → Management

This will enter the form for adding a new page - 
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with the following fields:

- Link Text , the name of the link, which will show up in the main navigation menu
- Page Type, it can be either a main page or a sub page of an already existing page
- Title, the title of the page, which will show up in the title tag
- Meta Description, the meta description of the page, which will appear in the meta description tag to 
be used for search engines optimization purposes
- Meta Keywords, the meta keywords of the page, which have to be entered as a list and will appear 
after that in the meta keywords tag on the page, to be used for search engines optimization purposes

Changing the pages hierarchy

You can modify the front site pages hierarchy by clicking on the Change Hierarchy button at the top of 
Website → Management  using the form at the bottom of the Website->Management page.7

This will open the change hierarchy form - this form there allows to make a page of the website either
a main page or a sub page of an existing main page.

Jobs Portal is a product of NetArt Media  www.netartmedia.net , All rights reserved

http://www.netartmedia.net/


Changing the position of two pages

By changing the position of 2 pages, you'll change the order of the pages in the main navigation menu
(for example replace the positions of the Home and About us pages).

Near every page on the Website->Management page, you could see 2  arrows indicating the up and
bottom directions, you have to click on them in order to change the position of the pages.

Please note that you can change the position of 2 pages only if they are on the same level in the
website hierarchy (for example main pages, or sub pages of the Home page etc.)

4.2. Modifying the content of the pages

The content of the pages can be modified from the Website->Management page in the admin panel. 
On this page, the administrator see the pages as a tree.

If the website is multi language, you need to choose the language version to manage by using the 
drop down to the left on Website → Management - this will switch between management of the pages 
of the different language versions. 

Please note that if you would like to modify the content of a page and the website is multi language, 
you need to do this for every language. For example modify the “Contact” page in the English version, 
then the “Contacto” page in the Spanish version etc.

To edit the content of a page like for example the Contact us page, the administrator has to click on it
and then choose either “Launch WYSIWYG editor” or the “Edit HTML code” option. 
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When using the Edit the HTML code option, you will be able to directly modify the html code of the
page, while with the first (Edit the page), a WYSIWYG (what you see is what you get) editor will open,
allowing to modify the content of the page.

Please note that the pages for which php files are set to be executed (the “Set Custom Extension”
option) can't be modified directly with the WYSIWYG editor. These pages can be easily distinguished
on the Website->Management page, near their name one could see with red font the name of the php
file to be executed, for example for “Latest Links”  this is “latest_links.php”.
The reason is that the code for these pages is rendered by the system, for example in the case of the
Latest Links page, it's generated by the file /extensions/latest_links.php (which is the jobseekers sign
up form), so the php code for it can't be modified with the WYSIWYG editor.

The page can be modified by editing directly the file for it or if only some texts need to be changed,
this may be done by modifying the language file (/include/texts_en.php for English).

4.5. Languages and language files

The language files contain the text and words shown on the user interface. For every language there 
is one language file located in the /include folder.
The name and location of the language file is: /include/texts_[CODE OF THE LANGUAGE].php
or for example /include/texts_en.php for English. The language file contains the different messages as 
PHP variables, for example:

$M_HIDE_RECENT_SEARCHES="hide recent searches";
$M_CLEAR_ALL="clear all";
$M_SEE_ALL="see all";
$M_WEBSITE_HOME="Website Home"; 
…

Translating the language file consists of translating the messages enclosed in brackets to the right, for 
example for Spanish:

$M_HIDE_RECENT_SEARCHES="ocultar búsquedas recientes";
$M_CLEAR_ALL="borrar todos";
$M_SEE_ALL="ver todos";
$M_WEBSITE_HOME = "Sitio Web - Inicio";

In order to add a new language on the website, it's necessary to add the translated file in the /include 
folder and also the administrator has to use the form on the Settings → Language Versions page and 
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enter the name of the new language for example “Deutsch” and the code for the new language, for 
example “DE”. 
The language code shows up after in the page links and is also used to for the name of the language 
file (in this case the language file will be /include/texts_de.php) and it's important to be 2 characters 
(like EN, DE, PT, TR etc).

5. Front site templates management

5.1. Templates overview

A template for the front site represents a standard HTML code mixed with some special   tags (the
compatibility with the  template system, makes possible the usage of templates and features from
other products using it, as well as combining different scripts and software products to work on one
website). 

A front site could be either set as a file called “template.htm” in the main website folder or it can be set
from the administration  panel  and  the Templates  → Modify  page.  If  both  are  available,  then the
template saved as a file “template.htm” will be used (it has higher priority).

You may fine below a brief description of the template system and tags and check also 6.3. Custom
HTML tags to see how you may create also your own custom tags with custom php files and code
executed for them.

When the different page are rendered on the front site, these special tags inserted in the template are
replaced by the corresponding content - let's consider the following example with a simple template:

<html>
<head>
<meta>
<title><site title/></title>
<meta name="description" content="<site description/>" />
<meta name="keywords" content="<site keywords/>" />
...

Jobs Portal is a product of NetArt Media  www.netartmedia.net , All rights reserved

http://www.netartmedia.net/


When the page is rendered, for example the tag <site title/> will be replaced with the page title (in
general the page titles can be set by the administrator from the Website → Management page), so
<title><site title/></title> will become:

<title>The page title will come here</title>

Please note that presence of none of these tags is obligatory, so you could combine them as you wish
in order to create the website and layout suiting the best your specific needs. Be aware also that
allows you to create your own tags (from the “Custom tags” in the back office) and set  php files
created by you to be executed and the generated content to be used in real time to replace the tag
with it.

Here are some most common tags used in the default templates of the different scripts based on :

<site title/> - Title of the web page 
<site description/> - Meta description of the web page 
<site keywords/> - Meta keywords of the web page 
<site menu/>- Main navigation menu of the website 
<site languages_menu/> - The languages menu of the website 
<site content/> - The main content of a page 
<site form/> - The custom server side forms for this page if there are any 
<site logins/> - The main log in form of the website
<site quick_search/> - The quick search form on the front site
<site news/> - The news (the administrator can manage them from the News page in the ADMIN)
<site featured_ads/> - The block displaying the featured ads
<site bottom_menu/> - The bottom menu displayed at the bottom of the site (it contains the same 
items as the main navigation menu)

Please note that depending on the current product or script you are using, not all these tags may be 
available on it.

To see your current template, the tags in it or modify it, please go to Templates in the administration 
panel.

5.2. Adding new templates and modifying the existing ones

In the Jobs Portal administration panel you may find the following pages related to the front site 
templates management:

Templates → Select a Template
The page offers the possibility to the administrator to select a template which will be used for the front
site between the currently available templates. Please note that in order to be able to select a template
for a given website, you need to add first the template (if it doesn't still exist)

Templates → Add a New Template
This page can be used to add new templates to the website. The administrator can add the new
template by directly pasting its HTML code.
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Templates → Modify

On this page the administrator can see the available templates and modify a selected template. In
order to select a template for modification, the administrator should click on the Modify icon and then a
new text area having the full template code will appear.

5.3. Custom HTML tags

The custom HTML tags provide a great way to expand the current functionality by creating your own 
php scripts to be executed and the content they output to be shown precisely in a selected position by 
the administrator.
This can be for example a php script calendar_tag.php showing a custom calendar, which needs to be
added at the top right corner of all pages of the website.

Creating a new custom tag is simple - the first step is to upload the corresponding PHP file in the
/extensions folder on your site. 
Please note the file names of php files, which will be used for tags should end with tag in their name –
for example calendar_tag.php or news_tag.php etc.
Then from the Extensions → Tags page in the administrator panel, fill  the tag name (for example:
calendar) and click on the Add button. This will create the tag - <site calendar/> in this example and it
will appear on the Tags page.

The tag should be defined from Extension → Tags and then inserted in the template or in the page
content.  When the page is  rendered all  the custom defined tags will  be  replaced by the content
generated by the script you set. 
The Tags page shows the current tags with their name, html code, the file to be executed (with a drop 
down listing all the uploaded tag files in the /extensions folder and a small delete icon allowing to 
delete the tag).

The final step when creating a new tag is to associate your tag with the php file you uploaded – this 
can be done by simply selecting the file from the File dropdown (“calendar_tag.php” in this example) 
and click on the Save button at the bottom of the page.
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After doing this, you can start using the tag by inserting it in the front site template (from Templates → 
Modify page) at the position you prefer in the template. 

5.4. Adding Google AdSense advertisements or Google Analytics

Very often the administrator may need to add external HTML code on website, it can be for example 
the HTML code for Google AdSense or other type of advertisements or Google Analytics code or a 
code provided by Google WebMaster Tools to verify the website.

Such HTML codes need to be pasted in front site template, which can be done from the Templates → 
Modify page in the administration panel. On this page, it's necessary to click on the Modify icon – this 
will show the HTML code of the template and paste the piece of HTML code for the banners, Google 
Analytics or similar.

When adding a counter or other tracking code like Googl Analytics, usually the best it to place it at the 
end of the template, for example just before the closing </body> tag.

For the advertisements the position will depend on what position exactly in the template (for example, 
top or bottom or to the right of the website pages etc.) the administrator would like to add them.

If you experience any difficulties when doing this, please don't hesitate to contact us and our support 
team will try to assist you asap.

6. Administration panel users and groups

The administrator has the possibility to create additional user groups for the main administration panel,
add users in them and assign their permissions. This can be done from “Users” in the administration
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panel.

This functionality can be used if for example there are multiple persons working on the website (for
example person A validating the listings posted by the users, person B responsible for the design of
the website and templates management, person C adding news on the website etc.)

6.1. User groups

The user groups make easier the permissions management for the users – instead of setting 
individually the permissions for every users, it can be be possible to create different user groups, add 
the users in them and manage the permissions per group.
For example, it can be possible to create a group of users who will be responsible only for posting 
news on the website “NewsAdministrators” and won't have access to the other pages like the ones for 
validating the listings etc.

To create a new user group, the only field the administrator has to fill is the group user name.

The page shows below also the list of the groups with their ID and a check box allowing to select one 
or many groups and delete them.

6.2. Adding new users

To add a new user, it's necessary to click on the New User button at the top of the User Groups page 
or choose directly from the main start menu Users → New User.

When adding a new user, it's necessary to select its Type or User Groups between the ones added by 
the administrator, enter his username, password, phone and email.
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To see a list of the current users or modify their information, it's necessary to go to the Users List page
(can be selected from the start menu Users → Users List or using the top buttons while in the Users 
category in the administration panel)

6.3. Permissions management

To set  the  permissions  for  the  different  user  groups,  it's  necessary  to  go  to  the  Users  → User
Permissions page in the administration panel.
The page shows a list of all the pages available by default in the  administration panel and a check
box for every box – to grant a permission for a selected page, it's necessary to check the box for it and
when when ready, to click on the Save button at the bottom of the page.

This will save the permissions sets for the user group.

An user,  member  of  an user  group,  which has been granted access to  only  some pages in  the
administration panel will see just these pages in the menus when he logs in.
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